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ACCESSING COURSE DATA

Download Course Data

Step 1. Navigate to the U-Spatial homepage, http://uspatial.umn.edu

Step 2. Click Training in the navigation menu at top of the page

Step 3. Under Workshops, Desktop GIS 101, click Workshop Materials to download the data

Extract Data to Local Storage

Step 4. Navigate to the location where you downloaded the data (likely the Downloads folder)

Step 5. Right-click on the GIS101 zip file and select Extract All...

Step 6. Extract the contents to the C drive by deleting everything after C:\ and clicking Extract

Note: For the remainder of the course, you’ll be able to access your data and maps by navigating to C:\GIS101



U-Spatial 4 

EXERCISE 1

Creating a Map

In this exercise, we’ll start by drawing a simple map from memory. Choose a location and try to represent it in map 
form. You might include streets and paths, trees and houses, or areas and borders. 
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EXERCISE 4

Opening ArcMap and Adding Data to Your Map

Step 1. Close any instances of ArcMap you may have already opened

Step 2. Navigate to C:\GIS101\Exercise Data\ and open Exercise 4.mxd

Step 3. Click the Add Data button in the toolbar

Step 4. In the Add Data window, click on the Connect To Folder button and connect to C:\GIS101\Exercise Data\

Step 5. Examine the contents of Exercise Data. It looks different in ArcMap than it does in Windows Explorer.

	 Completed Maps – finished versions of the maps you’ll create in each exercise
	 Exercises.mdb – a geodatabase containing all of the geographic data for today’s exercises
	 spps.xls, veterans1970.csv – two spreadsheets that we’ll use later in the course

Step 6. Double-click on Exercises.mbd to look inside. You’ll see a series of sub-folders, these are referred to as feature 
datasets in ArcMap. The different feature datasets contain the data for each of the upcoming exercises.

Step 7. Within Exercises.mdb, double-click on the Exercise 4 feature dataset and add MinnesotaCntys to your map.

Step 8. Retracing your steps from before, click the Add Data button again, click the Up One Level       button twice, 
and add the spreadsheet veterans1970.csv from the Exercise Data folder. 
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Joining Tabular Data to Spatial Data

Step 1. Right click on MinnesotaCntys in ArcMap’s Table of Contents and select Open Attribute Table. The table 
will display as either a stand-alone window or docked at the bottom of the screen. It will look something like this:

Step 2. Right click on veterans1970 in the Table of Contents and select Open. You should now see two tabs at the 
bottom of the table, one for veterans1970 and one for MinnesotaCntys:

To view both tables at once, click on the Table Options        button in the upper-left corner of the current table and 
choose Arrange Tables and New Horizontal Tab Group. You may need to resize the table window. 

Let’s examine both tables. In order to join these two tables we must first find a common field. A common field is a 
column that has the same information in both attribute tables and allows us to identify a unique row. In this case, 
GISJOIN is our common field. Try to find it in both tables.

Step 3. Close the attribute tables.
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Step 4. In the table of contents, right-click on 
MinnesotaCntys and select Joins and Relates and then 
Join... from the menu. 

In this process, we are going to join attributes from the 
veterans1970 spreadsheet to the features (counties) in 
the MinnesotaCntys file based on their common field, 
GISJOIN.

Step 5. Using the drop-down boxes, enter the following 
settings into the Join Data menu:

	 1. Field in this layer: GISJOIN
	 2. Table to join: veterans1970.csv
	 3. Field in the table: GISJOIN
	 4. Join options: Keep all records

	 Click OK to join the two files.

Note: In general, it’s best to click on Validate Join to 
check for any potential joining errors before clicking OK 
to complete the join.

Step 6. Open the attribute table for MinnesotaCntys and use the slider bar at the bottom of the table to scroll all the 
way to the right. If your join was successful, you should see the tabular data from veterans1970 appended to the far-
right of the MinnesotaCntys table:
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Step 7. These two tables appear to be joined, but the join is only temporary. If we were to close ArcMap now, we would 
lose this joined data. In order to make the join permanent, we must export the data as a new feature class. Do this by 
right-clicking on MinnesotaCntys in the table of contents and selecting Data > Export Data.

From the Export Data window, use the Browse         button to navigate to the Exercise 4 feature dataset. Note that you 
might have to change the setting under Save as type: from shapefile to File and Personal Geodatabase feature classes in 
order to see the Exercise 4 feature dataset. 

Step 8. Remove MinnesotaCntys and veterans1970.csv from your table of contents by right-clicking on them and 
selecting Remove. 

Step 9. Save your map (you can keep the same name) and close ArcMap. 

This is the end of Exercise 4. 

Once you’ve found the correct folder, enter 
MNVeterans1970 as the name for your file and click 
Save. 

When prompted, click Yes to add the exported data to 
the map as a layer.
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EXERCISE 5

Opening The Exercise Document

Step 1. Navigate to C:\GIS101\Exercise Data\ and open Exercise 5.mxd

Displaying Spatial Data

Step 1. The options for displaying spatial data are located in the Properties menu. Let’s look at the properties for 
MNVets1970. To do so, right click on MNVets1970 in the table of contents and select Properties. Then, click on the 
Symbology tab. Your screen should now look like this:

Step 2. At left, click on Quantities, then Graduated colors. 

Step 3. Next to Value under the Fields menu (NOT the Fields tab), select Vietnam from the drop-down menu. 
Recall that Vietnam is a field from our original spreadsheet that was joined to the shapefile of Minnesota counties. 
See the image below for reference. Select any color palette you’d like. If your other settings match, click OK. 
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Step 4. You now have a map showing raw counts of Vietnam veterans by county in Minnesota. This map shows 
a distinct spatial pattern: Hennepin County has the highest number of Vietnam veterans. However, we have not 
normalized (divided) the data by population, thus the veteran counts are not comparable across counties. We can 
figure out the percentage of Vietnam veterans by normalizing the number of veterans by the total population in each 
county. 

Step 5. Return to the Symbology tab under the Properties menu for MNVets1970. This time, keeping Vietnam as the 
value under Fields, select Pop1970 from the drop-down menu next to Normalization. Click OK to apply the changes.

The two maps below show Vietnam veteran data by county for Minnesota. The map at left shows raw counts, while 
the map at right shows Vietnam veteran counts normalized by total population. Take a moment to visually compare 
the two maps:

Raw Counts                                                                            Normalized

Step 6. Once again, return to the Symbology tab. At right, 
under Classification, click Classify... and spend some time 
testing out the different classification schemes and class 
numbers. After selecting a classification scheme, click 
OK in the Classification menu and then click Apply in the 
Layer Properties menu. Your map will update to display 
the data with the new classification scheme. Note: You 
may have to move the window to see your map.

Step 7. Back in the Symbology tab, test out the other 
methods for displaying quantities: Graduated symbols, 
Proportional symbols, and Dot density. Do this by clicking 
Apply for each classification method to view it on your 
map.

When you’ve finished exploring classification and 
symbology, return to a graduated color map showing 
Vietnam Veterans normalized by Total 1970 population.

Step 8. Click File, then Save to save your map. Stop here, Exercise 5 will continue after the next lecture.
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EXERCISE 5 CONTINUED

Important Map Elements

•	 Title
•	 Legend
•	 Scale Bar
•	 Sources
•	 Projection
•	 Color
•	 Geographical Context
•	 Visual Hierarchy

Working with Layout View

Step 1. Put your display in Layout View. To accomplish this, click on the small button located in the lower left hand 
corner of the display panel, immediately to the right of the table of contents. Hint: the button looks like a sheet of 
paper. 

You can think of layout view as a virtual page. We use layout view to add finishing touches to our map, such as the 
legend, scale bar, and title.

After switching to layout view, the layout toolbar becomes active. 

Take a moment to explore its tools:
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Step 2. Place 1/2 inch guides 
around the edge of your document 
to frame the workspace. Do this 
by single-clicking on the rulers at 
.5” and 8” on the horizontal axis 
and .5” and 10.5” on the vertical 
axis. You can adjust the guides by 
clicking and dragging. 

When your guides are appropriately 
placed, click and drag your map 
frame to meet the guides. It should 
snap into place. Take a look at the 
image at right for reference.

Alternatively, the data frame size 
can be adjusted by right-clicking 
on the data frame and specifying 
width and height values under size 
in the Size and Position tab. 

Use this method when specifying a 
precise data frame size is important. 

Step 3. Back on the data frame toolbar (not the layout toolbar), use the Zoom In       and Zoom Out       tools to fit 
the map comfortably in the center of the display area. Your goal is use the space as effectively as possible, limiting 
white space, while being careful to avoid cutting off any part of the map.

Add a Title

Note: A good title includes the theme, place, and time for the 
data being mapped.

Step 1. Select Text from the Insert menu. A tiny box containing 
the word Text should appear near the center of your map.

Step 2. Double-click on the text box to open its properties menu.

Step 3. Give your map a meaningful title, for example, “Vietnam 
Veterans in Minnesota by County, Census 1970.” It’s okay if your 
title takes up more than one line.

Step 4. Click on Change Symbol... to change the title font. 
Change the typeface, size, and style to your liking (at least 20 pt).

Step 5. Click OK twice and drag your title to the top of the map.
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Add a Legend

Step 1. Select Legend from the Insert menu. 

Step 2. In the Legend Wizard, make sure that MNVets1970 is 
included under Legend Items. If so, click Next.

Step 3. Erase the word Legend under Legend Title and click 
Next.

Step 4. If desired, select a border for your legend.

Note: Gap refers to the amount of space between the legend 
items and the border. A gap of 10.00 is common. Rounding 
is specified as a percentage, referring to the rounding of the 
border’s corners. It is not necessary to change the default 
settings.

Step 5. Click Next, Next, and Finish to exit the Legend 
Wizard.

Step 6. Move your legend to an appropriate place on your 
map.

Step 7. In the table of contents, click the List by Drawing 
Order button in the upper left-hand corner. This allows for 
a simplified view of the legend and will let us rearrange our 
layers as we add them in the following  steps.

Step 8. Still working in the table of contents, re-label the 
legend by clicking on MNVets1970 , pressing F2, and then 
entering a more appropriate title, such as “Vietnam Veterans.” 
Press the Enter key to update the title. Notice the change 
reflected in your map’s legend. See the example at right.

Step 9. Click on Vietnam / Pop1970, press F2, remove the 
label by pressing Backspace or Delete.

Step 10. Next, let’s format the numbers in the legend to make 
them easier to read. Since these numbers represent percentages 
of veteran population, we’ll change them accordingly. To do 
so, right click on MNVets1970 in the table of contents, select 
properties, and open the symbology tab. Click on Label and 
select Format Labels...
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Step 11. Select Percentage from the Category menu. Then, click the 
radio button next to “The number represents a fraction. Adjust it to show 
a percentage.” Click on Numeric Options... and reduce the number of 
decimal places to 2. Click OK  on all of the proceeding windows until 
you’re back to your map. Take a look at your legend to verify that it’s 
displaying as a percentage.

Add a Scale Bar

Step 1. Select Scale Bar from the Insert menu

Step 2. Select an appropriate scale bar, such as Scale Line 1

Step 3. Click on the Properties button to examine the scale bar 
options. Make sure that Miles is listed under Division Units. Click 
OK twice to place the scale bar on your map.

Note: Be sure to select an appropriate division unit for your maps. 
In this case, miles are a logical choice for division units, but that 
wouldn’t necessarily be the case at a different scale or geographic 
location.

Step 4. Let’s make a few edits. Double-click on the scale bar to open 
its properties menu. In the dropbox below When resizing..., choose 
Adjust width. Then, change the Division value to 100 mi and the 
Number of divisions to 1.

Step 5. Lastly, place your scale bar in an appropriate place on your 
map.

Add Sources and Text

Step 1. We’ll use the same steps we used to insert a title to insert 
our source information. (Hint: Insert > Text). Be sure to reduce the 
font size using the options under Change Symbol...

Step 2. Enter your name, the data source(s), and the date the map 
was created.

Step 3. Place your sources somewhere out of the way, such as the 
bottom corner or under the legend.
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Projections

Note: Thousands of projections exist! We will not cover them in detail in this course. We’ll be using a State Plane 
projection designed for central Minnesota in this exercise, though we have a number of other options. 

Step 1. Right-click on Layers in the table of contents and select Properties. Navigate to the Coordinate System tab. 

Step 2. Type “State Plane” in the projection search box.

Step 3. Click through the file tree in the following order to find the desired projection: Projected Coordinate 
Systems > State Plane > NAD 1983 (US Feet) > NAD 1983 StatePlane Minnesota Central FIPS 2202 (US Feet). 
When you’ve found it, select it and click OK.

Note: After projecting, you may need to adjust your map using the zoom and pan tools. Do so now. 

Color

Note: ColorBrewer (colorbrewer2.org) is a fantastic resource for color options for 
cartography. In addition to offering a wide range of color ideas for different types 
of data, ColorBrewer also allows you to select colors that are colorblind safe, printer 
friendly, or photocopy-able. Remember to follow best practices from lecture when 
selecting your colors!

To download the ColorBrewer styles:

Step 1. Navigate to http://tinyurl.com/lhcxf52
Step 2. Click on the yellow “download” button
Step 3. Click the radio button to agree to the license agreement and click the yellow 
“download” button again
Step 4. If prompted, save the file to your downloads folder. Otherwise, it will save there 
by default.
Step 5. Navigate to your downloads folder
Step 6. Right-click on the folder you downloaded, AS14403, and select Extract All…
Step 7. Extract the file, ColorBrewer.style, to a meaningful location (e.g. a flash drive, 
your current workspace, etc.)

To load the ColorBrewer styles into ArcMap:

Step 1. In ArcMap, click Customize on the main menu bar and select Style Mangaer…
Step 2. Click Styles… on the right side of the Style Manager window
Step 3. Click Add Style to List… 
Step 4. Navigate to the location where you extracted the ColorBrewer.style file, select it, 
and click Open
Step 5. Click OK and then Close

You will now see the ColorBrewer styles when you examine the color ramps drop-down 
in the symbology menu. Take a few minutes to browse through the color ramps and 
select one for your MN Veterans data.
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Geographical Context

Step 1. Click the Add Data button

Step 2. Navigate to C:\GIS101\Exercise Data\Exercises.mdb\Exercise5 
and add LakeSuperior and BorderStates to your map.

Note: You can add multiple datasets at once by holding down Ctrl or 
Shift while selecting the data.

Step 3. Reorder the files so that Vietnam Veterans is the topmost layer 
in the table of contents. 

Step 4. Remove BorderStates and LakeSuperior from the legend. Do 
this by double-clicking on the legend and opening the General tab. 
Click on the unwanted items under Legend Items and use the “<” 
button to remove them from the box.

Step 5. Change the fill colors for BorderStates and LakeSuperior to 
something more appropriate. 

Step 6. Change the data frame’s background color to make it look 
as though we have a data layer for Canada. Right-click in the white 
space above Minnesota and select Properties... Next, click on the 
Frame tab and select a light gray fill for the background. Click OK.

Step 7. Save your map and close ArcMap. Congratulations, you’ve 
just completed a basic thematic map!

Optional Challenge: Geographical Context

Finished early and feeling up for an additional challenge? 

In the exercise above, we simply changed our map’s background color to imitate a shapefile for Canada. Now, let’s 
see if we can find an actual shapefile to put in its place.

Step 1. Using a web search, locate a shapefile of Canada’s provincial boundaries.

Step. 2. Download and unzip the file.

Step 3. Connect to the folder in which you unzipped the shapefile and add it to your map.

Step 4. Symbolize the layer appropriately and remove it from the legend.

Which step was the most time-consuming?
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EXERCISE 6

A Definition of Geocoding

Geocoding is the process of assigning geographic coordinates to an address. In other words, it’s the process we use to 
transform a table of addresses into a series of corresponding points on a map.

Prepare Data for Geocoding

Step 1. Open Exercise 6.mxd from the Exercise Data folder

Step 2. Click the Add Data button and add the following layers:

	 GIS101\Exercise Data\Exercises.mdb\Exercise 6\Stpaul - A polygon shapefile of St. Paul
	 GIS101\Exercise Data\Exercises.mdb\Exercise 6\Stpaulrds -  A line shapefile of St. Paul roads
	 GIS101\Exercise Data\spps.xls\Sheet1$ - An Excel table of St. Paul Public Schools

Step 3. Make Stpaul a light gray color and Stpaulrds two shades darker. 	

Step 4. Change the data frame’s projection to Ramsey County (NAD 1983 HARN Adj, US Feet) 

We’ll use this simple map as a background to help us visualize the school location data we’re about to geocode.

About Address Locators

An Address Locator is a dataset that includes important information for matching addresses, including address 
attributes. There are a number of different styles of address locators for various address formats around the world. In 
this activity, we are using an address locator that was created based on St. Paul’s road network.

Geocoding Addresses 

Step 1. Right-click on Sheet1$ in the table of contents and select     
Geocode Addresses...

Step 2. Choose StPaulAddressLocator from the pop-up when prompted 
to choose an address locator. Note: You will need to click Add... and 
then navigate up to Exercises.mdb to locate StPaulAddressLocator.

Step 3. Make sure Address is selected as the field next to Street or 
Intersection and Zip is selected for ZIP Code. The geocoder will use 
these fields to locate addresses. 

Step 4. Change the Output Feature Class so your output file is called 
StPaulPublicSchools and it is located in the Exercise 6 feature dataset 
within the Exercises Database. Click OK to geocode the addresses.
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Step 5. This brings up the Geocoding Results Menu. Your results may 
differ, but in the example at right we see that 60 schools were matched, 
0 were tied, and 5 were unmatched. We’ll look at rematching addresses 
in a moment. For now, click Close.

You should see something like this on your screen. Each dot on the 
map represents one of the 60 successfully-geocoded addresses. Your 
table of contents likely says “Geocoding Result: StPaulPublicSchools.” 
Change the layer name to St. Paul Public Schools.

Step 6. Right-click on St. Paul Public Schools in the table of contents 
and select Data > Review/Rematch Addresses... to bring up the Interactive 
Rematching window. 

We’ll be using this interface to correct the addresses that weren’t 
matched when we geocoded our table of St. Paul public schools. 

Step 7. Select Unmatched Addresses from the drop-down in the 
upper-left hand corner of the Interactive Rematching window, next to 
Show Results. This simplifies things by only showing us the unmatched 
results. 

Note: You’ll  need to scroll over to the right to find the important 
information in the table (e.g. school name, address, etc.).

Step 8. Use the web to find the problems with your unmatched 
addresses. There may be errors in the address or zip code. When you’ve 
found the correct address, enter it into the Address box in the lower-left 
corner and hit the Enter key to update the list of candidates. When you 
have a match above 80%, select it and click Match in the lower-right 
corner and continue on until all addresses are matched.
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Optional Challenge: Symbolize Schools by Type

Our dataset includes elementary, middle, and high schools. As such, it might be useful to use a unique symbol for 
each school type on our map.

Step 1. Right-click on St. Paul Public Schools in the table of contents and open its layer properties window

Step 2. Click on the Symbology tab if it is not already selected

Step 3. In the left pane, under Show:, select Categories and then Unique values

Step 4. Select Type from the Value Field drop-down

Step 5. Click on Add All Values 

Step 6. Double-click on the symbol for each school type and change it to something appropriate

Step 7. Save your map and close ArcMap
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EXERCISE 7

Exercise Objectives

In this exercise, we’ll employ three techniques from lecture: 

	 1. Selecting by Attributes
	 2. Selecting by Location
	 3. Spatial Join

Getting Started

Step 1. Open the Exercise 7.mxd map document from the Exercise Data folder.

Step 2. Verify that there are three layers on your map — schools, roads, and the city boundary for Saint Paul.

Step 3. Add convstores to your map from the Exercise 7 feature dataset. These points represent convenience stores. 
They have already been geocoded for you. Change the layer symbol to something that contrasts with the schools layer.

Selecting by Attributes

Before we start asking questions about our data, (such as, “How many 
convenience stores are within 1/4 mile of a school?”) let’s focus our 
analysis by extracting out only the high schools in St. Paul. To do so, 
we’ll select them from the schools layer and export them as a new layer.

Step 1. On the main menu, click on Selection and choose Select by 
Attributes... from the drop-down menu. 

Now, using the Select By Attributes window, we’re going to build a 
selection query to select only the high schools.

Step 2. For Layer:, select StPaul_Schools. For Method:, choose Create 
a new selection. 

Step 3. Scroll down and double-click on [Type] from the menu. Once 
clicked, it should appear in the text box at the bottom of the window. 

Step 4. Click on the “=” button from the menu at center. 

Step 5. Click on Get Unique Values to bring up a list of all the values in 
the Type field. Double-click on ‘High’ from the menu.

Your selection query should read: [Type] = ‘High’

Step 6. Click OK to run the selection query.
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Notice that some of the schools turned blue. These are the selected 
features. In this case, they are the high schools. 

Next, let’s export them as a new layer.

Step 7. Right-click on StPaul_Schools in the table of contents and select 
Data > Export Data. 

Step 8. Save the new layer as HighSchools in your Exercise 7 feature 
class. When prompted, click Yes to add the layer to the map.

Selecting by Location: A Case Study

Let’s use our new layer of high schools for a little case study. Suppose we’re working in the public health field and we 
want to find out which convenience stores are located within walking distance of a high school in St. Paul. Information 
like this might be useful in targeting obesity among high school students — convenience stores are stocked with candy, 
soda, and other unhealthy products at relatively inexpensive prices. 

Our goal is to reach out to convenience stores owners whose stores are located within one mile of a high school.

Selecting by Location: Procedures

Step 1. In the Selection drop-down, select Clear Selected Features to 
remove your previous selection.

Step 2. Back in the selection drop-down, choose Select By Location...

Step 3. Modify the Select By Location settings as follows:

	 1. Selection method: Select features from
	 2. Target layer(s): convstores
	 3. Source layer: HighSchools
	 4. Spatial selection method: Target layer feature(s) are within 	
	      a distance of the source layer feature
	 5. Apply a search distance: 1.0 Miles

Step 4. Click OK to view the convenience stores that are within one 
mile of a high school.

Step 5. Export the selected features from the convstores layer as a new 
layer and change their symbology to distinguish them as a feature of 
interest. Hint: Right-click on convstores, data > export data.
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Buffering

Using the Select by Location tool allowed us to see which convenience 
stores are within a certain distance of high schools, but what if we want 
to know how many convenience stores are within a certain of all schools?

In this section, we’ll create a 0.5 mile buffer zone around each school. 
In the following section, we’ll spatially join the buffered layer and the 
convenience stores layer to get a count of the convenience stores within  
half a mile of each school.

Step 1. Make sure your table of contents contains convstores, StPaul_
Schools, StPaul_Roads, and Stpaul_Bndry. You can remove the other 
layers. 

Step 2. Locate the Buffer tool from the Geoprocessing drop-down 
menu. Note: Alternately, you can access it through ArcToolbox > 
Analysis > Proximity > Buffer.

Step 3. With the Buffer window open, enter the following settings:

	 Input Features: StPaul_Schools
	 Output Feature Class: ...Exercise7\SchoolsBuffer
	 Linear unit: 0.5 Miles

Step 4. Click OK. You should see a half-mile buffer around each 
school in a new layer called SchoolsBuffer.

Spatial Join

Step 1. Right-click on SchoolsBuffer in the table of contents and select 
Joins and Relates > Join... to open the Join Data menu. 

Step 2. Enter the following settings in the Join Data menu:

   What do you want to do to join this layer? Join data from 	                 	
    another layer based on spatial location
   Choose the layer to join to this layer...: convstores
   Click the button for “Each polygon will be given a 		
   summary of the numeric attributes...”
   Save the new file as: ...\Exercise 7\SchoolsBuff_Stores
   Press OK

Step 3. Open the attribute table for SchoolsBuff_Stores. Scroll to 
the right and find the field called Count_. It contains the number of 
convenience stores within a half mile from each school. Sort this column 
by right-clicking on the field name and selecting Sort Descending... 
Which school is surrounded by the most convenience stores?

Step 4. Congratulations, you’re done! Save and close ArcMap.
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EXERCISE 8
Exercise Objectives

In this exercise, we’ll employ the following techniques from lecture: 

	 1. Selection using the select tool
	 2. Selecting by location
	 3. Selection by attributes
	 4. Buffer
	 5. Intersect
	 6. Dissolve

Our goal is to determine the best place for a nature lover to live in Minnesota, based on the following criteria:

	 1. In a town with a population greater than 1,000 people
	 2. Within two miles of a boat trailer launch 
	 3. In a state forest
	 4. In an area of mixed deciduous and coniferous forest

Getting Started

Step 1. Open Exercise 8.mxd from the Exercise Data folder. You should see a map document with a layer called States 
(turned on) and a layer called Cities (turned off). 

Using the Select Tool

Firstly, we need to select Minnesota from the States layer and export it 
as a new layer for focused analysis. We aren’t concerned with the rest of 
the country in this activity.

Step 1. Click on the Select Features tool in the toolbar

Step 2. Click on Minnesota to select it. When selected, the border 
should turn cyan blue.

Export Minnesota

Step 1. Right-click on the States layer in the table of contents and 
choose Data > Export Data. 

Step 2. Browse to the Exercise 8 feature dataset and save your new layer 
as Minnesota.

Step 3. When prompted, click Yes to add the layer to the map.

Step 4. Remove the States layer from your map.



U-Spatial 24 

Select by Location

Using the Select by Location tool, we’re now going to select all of the 
cities that are within Minnesota.

Step 1. Turn on the Cities layer by checking the box next to its name 
in the table of contents. You should see cities for the entire country. 

Step 2. From the Selection menu in the topmost toolbar, choose Select 
By Location... Here, we’re going to select features from the Cities layer 
that intersect the Minnesota layer.

Step 3. Enter the following settings to select the desired features:

	 Selection method: select features from
	 Target layer(s): Cities
	 Source layer: Minnesota
	 Spatial selection method: Target layer(s) features intersect 	
	 the Source layer feature

Step 4. Click OK. All Minnesota cities should now be selected.

Export Minnesota Cities

Step 1. Like we did earlier in the exercise, right-click on Cities in the table of contents and select Data > Export Data.

Step 2. Browse to the Exercise 8 feature dataset and save the new layer as MNCities.

Step 3. Add the new layer to the map and remove the Cities layer (right-click, Remove).

Data Management

Before we move on, let’s take a moment to get our bearings and clean 
up any extraneous data. At this point you should only have two layers 
on your map: MNCities and Minnesota. Remove any other layers. 
Then, click the Full Extent button     in the toolbar. 

Minnesota and its cities should fill your data frame. Getting rid of layers 
once they’re no longer necessary will help us keep our data organized 
throughout the activity. Repeat this process for each successive step in 
this activity. 

Note: In the image at right, Minnesota has been projected into 
WGS 1984 UTM Zone 15N, another commonly used projection 
for Minnesota. You might consider projecting your data frame 
(Hint: Layers > Data Frame Properties > Coordinate System) before 
proceeding with this exercise. 
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Select by Attributes

Because we know we’re only looking for towns with more than 1,000 
people, we can remove any cities with fewer than 1,000 inhabitants. To 
do so, we’ll use the Select by Attributes tool.

Step 1. From the Selection menu in the topmost toolbar, choose Select 
By Attributes... 

Step 2. Do the following to build the appropriate selection query:
	
	 1. Layer: MNCities
	 2. Method: Create a new selection
	 3. Double-click on [POP_98] in the attribute box
	 4. Click on the > (greater than) button
	 5. Type 1000 in the box below to complete the query
	
	 Your statement should read: [POP_98] > 1000

Click OK to run the selection query. All of the cities in Minnesota with 
a population greater than 1,000 are now selected.

Step 3. Export the selected cities as a new layer called MNCities1000. 
Add it as a new layer and delete the MNCities layer.

Buffer

Our next step is to figure out which areas are within two miles of a boat 
trailer launch site. We’ll do this by creating a 2-mile buffer around each 
launch site.

Step 1. Click the Add Data button and choose TrailerLaunchSites 
from the Exercise 8 feature dataset.

Step 2. Locate the Buffer tool from the Geoprocessing drop-down menu 
(or via ArcToolbox > Analysis Tools > Proximity > Buffer).

Step 3. Enter the following settings in the Buffer tool window:

	 Input Features: TrailerLaunchSites
	 Output Feature Class: ...\Exercise 8\TrailerBuffer
	 Linear unit: 2 Miles

	 Accept defaults for the rest and click OK.

Step 4. Once your new TrailerBuffer layer is added, remove 
TrailerLaunchSites from your map.
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Intersect

Although we can now see which cities have 1,000+ residents and are 
within two miles of a boat trailer launch site, we still need to figure out 
which towns are within a state forest AND in a mixed forest. 

Step 1. Add StateForest and MixedForest from the Exercise 8 feature 
dataset.

Step 2. Create a layer containing the intersection of these to layers. Do 
this by selecting the Intersect tool from the Geoprocessing drop-down 
(or via ArcToolbox > Analysis Tools > Overlay > Intersect).

Step 3. In the Intersect window, enter the following:

	 Input Features: StateForest, MixedForest
	 Output Feature Class: ...Exercise 8\ForestIntersect 

Step 4. Click OK. In this step, we’ve created a new, simplified layer 
containing only the areas in which state forests and mixed forests over-
lap.

Step 5. Remove StateForest and MixedForest

StateForest and MixedForest ForestIntersect

Intersect, Again

Next, we’ll intersect the ForestIntersect and TrailerBuffer layers to find areas that are in a state and mixed forest AND 
are within two miles of a boat trailer launch. 

Step 1. Run the Intersect tool again, this time with the following settings:

	 Input Features: ForestIntersect and TrailerBuffer
	 Output Feature Class: ...\Exercise 8\ForestTrailerIntersect
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	 Click OK. 

A new layer containing the intersection of the two layers should be visible. Remove ForestIntersect and TrailerBuffer.

ForestIntersect and TrailerBuffer ForestTrailerIntersect

Dissolve

We can dissolve the new layer in order to make its boundaries easier to see. 

Step 1. Select the Dissolve tool from the Geoprocessing drop-down (or via ArcToolbox > Data Management Tools > 
Generalization > Dissolve).

Step 2. Enter the following settings:

	 Input Features: ForestTrailerIntersect
	 Output Feature Class: ...\Exercise 8\ForestTrailerDissolve
	
	 Accept the defaults for the other settings and click OK.

Step 3. Remove ForestTrailerIntersect.

ForestTrailerIntersect (zoomed in) ForestTrailerDissolve (zoomed in)
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Determine the most desirable place to live!

Finally, determine which city from MNCities1000 meets all of the criteria. Note: You may need to add MNCities1000 
to your map if you deleted it earlier.

Use the Select by Location tool to find out which city from MNCities1000 falls within the ForestTrailerDissolve layer. 
There should only be one!

Hint: Refer to page 24 if you need a refresher on how this tool works.

One you have a city selected, right-click on MNCities1000 and open its attribute table to view the name of the city. 
Alternately, you can select Zoom To Selected Features from the Selection drop-down and use the Identify tool to click 
on the city for more information.

Found the answer? Congratulations! You can verify the name of the city below.

Save your map and close ArcMap.

Answer: Cross Lake, MN


